Unable to progress past 2-11

Home Forums Info on Bug Reporting Unable to progress past 2-11

Viewing 0 reply threads
  • Author
    Posts
    • #14921
      Avatarpsychosquirrel02
      Participant

      Spoke to Captain Brinebeard, who goes thru his details of wanting his treasure. Accepted quest. Quest info at top left gives just “Follow the mine to find and retrieve the Captain’s lost treasure map.”. I’ve found/ followed the mine and picked up the treasure map, but no matter what I do, the Captain just says to feel free to use his cannons. I’ve tried using all the cannons just to be thorough, but nothing worked.

      Before talking to the captain I explored the island thoroughly and found boththe map and the hook–maybe that threw everything out of synch? I tried dropping the map and hook and restarting game, and even tho the map respawns each time, i cannot progress.

      I watched other people’s videos of this quest and they have a second bullet point to the quest info at the top left saying to give the map to the captain. I do not have that text.

Viewing 0 reply threads
  • You must be logged in to reply to this topic.

This website uses cookies to improve user experience. By using our website you consent to all cookies in accordance with our Cookie Policy.

Accept this cookie Find out more